ProSoundWeb Community

Please login or register.

Login with username, password and session length
Advanced search  

Pages: [1]   Go Down

Author Topic: EAW JFL213 crossover help  (Read 256 times)

Jon Ross

  • Jr. Member
  • **
  • Offline Offline
  • Posts: 80
  • Virginia
    • RoTech Sound
EAW JFL213 crossover help
« on: June 01, 2018, 06:58:48 pm »

Ive spent some time today trying to diagnose an issue I had with one of my JFL213 cabinets on a gig the other day. The cabinet seemed to go out mid gig as in no sound at all. I say seemed because it may have been possible just HF stopped working. In the heat of the moment I changed amp channels and the speaker cable to no avail. The amp channel was going into protect so I swapped the cab for one that was being used as a fill and finished the gig. I was using these in passive mode and single box HF mode whereas I usually biamp these and use multiple boxes per side.
On to finding the issue.
Ive tested all the drivers and all 5 in this box are working. Next I was able to locate a melted coil on the crossover board and found the root of the problem being two swapped terminal connectors. The connector is the same but they go to 2 different spots on the crossover. Doh! The swap happened a while ago during a minor crossover component repair.
Next, while testing, I found one of the 10s to be noticeably quieter than the other. I swapped the 10s and the problem stayed the same. Tried another JFL213 and it was the same, one 10 louder than the other. Tried another 213, same thing. I was under the impression that this was only a 2way box. It does have one of EAWs famously complicated crossovers, but this seems weird to me. I also figured out that the two 10s must be in series because if you disconnect the louder one, they both stop working. If you only disconnect the quieter one the other still works though.
Anyone have any insight? Or experience inside this box.
« Last Edit: June 01, 2018, 10:21:22 pm by Jon Ross »
Logged

Helge A Bentsen

  • Hero Member
  • *****
  • Offline Offline
  • Posts: 673
  • Oslo, Norway.
Re: EAW JFL213 crossover help
« Reply #1 on: June 02, 2018, 03:44:48 am »

The 10 are in series, I usually replace both when one fails.

Are you sure you have the correct limiter settings on these boxes? They sound good but the crossovers doesnt survive excess power.

Case in point, I had a customer burn all the crossovers and 10 in six boxes, they literally caught fire because his amps came back from service in input sensitivity, not voltage gain. He went straigt for a gig without checking this and his UX was set for 32dB VG...

EAW sell the crossovers in two parts, Id recommend replacing the burned board instead of looking for failed components.
Logged
Pages: [1]   Go Up
 


Page created in 0.032 seconds with 21 queries.