ProSoundWeb Community

Sound Reinforcement - Forums for Live Sound Professionals - Your Displayed Name Must Be Your Real Full Name To Post In The Live Sound Forums => DJ Forum => Topic started by: Kyle Espinoza on February 06, 2012, 05:51:58 pm

Title: Behringer 502 trouble
Post by: Kyle Espinoza on February 06, 2012, 05:51:58 pm
Hello everyone,
I'm fairly new to working with audio hardware and I just received a behringer 502. The speakers I am trying to use were originally part of the Samson exp 5 10i portable PA system and both work fine. When I connect them to my behringer the sound quality is greatly reduced and the volume stays relatively low even when the master and input volume is maxed. I tried this using the tape/cd input from an ipod, and using a microphone as well, both are extremely quiet. I'm not sure what I'm doing wrong, if it has to do with the speakers or the input sources. Can anyone help?

Kyle
Title: Re: Behringer 502 trouble
Post by: g'bye, Dick Rees on February 06, 2012, 07:16:08 pm
Hello everyone,
I'm fairly new to working with audio hardware and I just received a behringer 502. The speakers I am trying to use were originally part of the Samson exp 5 10i portable PA system and both work fine. When I connect them to my behringer the sound quality is greatly reduced and the volume stays relatively low even when the master and input volume is maxed. I tried this using the tape/cd input from an ipod, and using a microphone as well, both are extremely quiet. I'm not sure what I'm doing wrong, if it has to do with the speakers or the input sources. Can anyone help?

Kyle

Kyle.....

The Samson speakers were receiving proper signals from the Samson POWERED mixer they came with.  The Behringer 502 does not contain a power amplifier like the original Samson powered mixer.  You need to have an amplifier to power the speakers.  You cannot replace a powered mixer with an unpowered mixer and expect it to work.
Title: Re: Behringer 502 trouble
Post by: John Livings on February 06, 2012, 09:40:58 pm
This may help;

http://www.google.com/search?client=safari&rls=en&q=active+vs.+powered+speakers&ie=UTF-8&oe=UTF-8

Regards,  John