Sound Reinforcement - Forums for Live Sound Professionals - Your Displayed Name Must Be Your Real Full Name To Post In The Live Sound Forums > Pro AV Forum

Lab Gruppen fp6400 conversion help

<< < (2/4) > >>

Caleb Dueck:

--- Quote from: Kelso Kline on March 05, 2024, 08:19:35 PM ---I recently acquired a couple of fp6400 amplifiers. The Oddity is that these are labeled on the back as the 115 volt version, but there is a piece of Gaff tape with 230v written on it. They all have the 30A locking connectors on them. When I connected one to 30A to 20a plug adapter and plugged it in, it Powers on, but the fuse protection light is on. Could these have been modified to 230v? How can I tell? Additionally, if I do plug it into a 230v line, could I cause serious damage or would the fuse protection activate?

--- End quote ---

Do NOT plug it into 230V unless you are absolutely sure it's the correct model.  We did that once (mislabeled amp) and created an immediate smoke machine. 

They're good amps still, not my first choice for subwoofer duty.  The lack of universal voltage was one of the small reasons why we switched (to Powersoft and then Linea).

Kelso Kline:

--- Quote from: Caleb Dueck on March 07, 2024, 03:29:37 PM ---Do NOT plug it into 230V unless you are absolutely sure it's the correct model.  We did that once (mislabeled amp) and created an immediate smoke machine. 

They're good amps still, not my first choice for subwoofer duty.  The lack of universal voltage was one of the small reasons why we switched (to Powersoft and then Linea).

--- End quote ---
This is my concern as well! I've taken some internal pictures, but I don't see any jumpers, nor do I see any sloppy soldering work to give the indication that it has been worked on. My goal is to confirm that these are usable, then have them serviced. Being that there's only five service centers in the US, and every one of them is over 500 miles away from me, I'd like to know that these are operational beforehand.

Lee Douglas:
Caleb, I thought those amps had over voltage shut down on them?  Kelso, can you share the pictures you took?

Kelso Kline:

--- Quote from: Lee Douglas on March 07, 2024, 07:24:59 PM ---Caleb, I thought those amps had over voltage shut down on them?  Kelso, can you share the pictures you took?

--- End quote ---
Sure!

Lab Gruppen fp6400 amplifier https://imgur.com/gallery/dTbX5gu

https://imgur.com/gallery/YVFAQqw

Scott Holtzman:

--- Quote from: Kelso Kline on March 07, 2024, 08:26:52 PM ---Sure!

Lab Gruppen fp6400 amplifier https://imgur.com/gallery/dTbX5gu

https://imgur.com/gallery/YVFAQqw

--- End quote ---


That link doesnt work, do you have the permissions set right? 


If you don't want to deal with these amps and would rather get something with autovoltage I will take them off your hands. 

Navigation

[0] Message Index

[#] Next page

[*] Previous page

Go to full version