ProSoundWeb Community

Please login or register.

Login with username, password and session length
Advanced search  

Pages: 1 [2]  All   Go Down

Author Topic: Crown iTech 6000 cutting in/out  (Read 738 times)

Jay Marr

  • Hero Member
  • *****
  • Offline Offline
  • Posts: 640
Re: Crown iTech 6000 cutting in/out
« Reply #10 on: January 08, 2020, 07:36:57 pm »

@Jay Marr - I just sent you an email with some additional information.

Thanks, would appreciate any info.  Email didn't get to me yet, but you can also email me at blindbynoon(at)comcast.net

Waiting for AE Techron to call me back.  Their list of serviceable amps did not include Itech (non HD) models.  So they're checking with the 'guy' who services the amps, to see if he can.

Logged

Tracy Garner

  • Sr. Member
  • ****
  • Offline Offline
  • Posts: 303
Re: Crown iTech 6000 cutting in/out
« Reply #11 on: January 09, 2020, 01:01:23 pm »

Thanks, would appreciate any info.  Email didn't get to me yet, but you can also email me at blindbynoon(at)comcast.net

Waiting for AE Techron to call me back.  Their list of serviceable amps did not include Itech (non HD) models.  So they're checking with the 'guy' who services the amps, to see if he can.

I sent the last email out of the PM but I sent this email using the email above. Hope it helps.
Logged

Jay Marr

  • Hero Member
  • *****
  • Offline Offline
  • Posts: 640
Re: Crown iTech 6000 cutting in/out
« Reply #12 on: February 04, 2020, 09:23:07 am »

As a follow up and PSA:

I contacted AE Techron and they do not really service iTech (non-HD) any longer.  I got 3 answers from them, and the general consensus was 'maybe' we can fix it, and I need to ship and pay a bench fee to get it looked at it (so this was going to be my last resort).

I contacted the nearest certified Crown repair center near me (which is in Lawrence or Methuen, MA).  They said they would have to send the amp to Crown to service, and they don't repair amps.

I contacted Crown and they could not help. Their best suggestion was to call The Tone Garage.

Recommendation from Forum members as well to call The Tone Garage, so I did that.

Jay at Tone Garage responded to my email very promptly and gave me an upfront flat fee price to fix/service the amp (without a full diagnosis, just my description of the issue).  I sent it out via UPS and it was expected to get their on a Friday.  I got an email from Jay on that Friday it was arriving, saying the amp was done and ready to ship back!  Maybe UPS got it there early (Thursday), but either way, VERY quick turnaround.
He did replace the ribbon cable, that's about all I know about the repair.

Amp arrived, and I put it back in the rack last night.  Going to fire it up tonight and perform some tests and take it out to a gig this weekend.

The PSA here is - if you need an iTech serviced, The Tone Garage (in Cali) is a great option.
« Last Edit: February 04, 2020, 09:28:15 am by Jay Marr »
Logged

ProSoundWeb Community

Re: Crown iTech 6000 cutting in/out
« Reply #12 on: February 04, 2020, 09:23:07 am »


Pages: 1 [2]  All   Go Up
 



Page created in 0.053 seconds with 23 queries.