ProSoundWeb Community

Please login or register.

Login with username, password and session length
Advanced search  

Pages: 1 ... 4 5 [6]   Go Down

Author Topic: Turbosound IP2000 getting 'crackling' sound with keyboards  (Read 8552 times)

Mac Kerr

  • Old enough to know better
  • Administrator
  • Hero Member
  • *****
  • Offline Offline
  • Posts: 6348
  • Audio Plumber
Posting Rules
« Reply #50 on: May 22, 2018, 04:43:57 pm »

I'm glad to have found this post

Please go to your profile and change the "Name" field to your real first and last name as required by the posting rules displayed in the header at the top of the section, and in the Site Rules and Suggestions in the Forum Announcements section, and on the registration page when you registered.

Mac
admin
Logged

Christopher Parker

  • Newbie
  • *
  • Offline Offline
  • Posts: 3
    • The Jen Thayer Band
Re: Turbosound IP2000 getting 'crackling' sound with keyboards
« Reply #51 on: September 05, 2018, 03:33:36 pm »

I have a pair of these.  They worked really well for 6 months.  I was doing an 11 piece horn band and a 9 piece Disco band with ease.  And they sounded great.  I did have additional sub supports.  Recently one started to distort in one of the upper towers when a male was singing.  The other developed a loose piece inside.  I sent both back for service and they are on their way back to me.  They claim to have fixed the loose bit and that otherwise they are fine.  Well we will see. 

I guess my issue is a lot like the OP.  As the gig went on the top would start to distort.  Not really bad but a good listener would notice it.

I will write back when I get them beck. 
Logged
Pages: 1 ... 4 5 [6]   Go Up
 


Page created in 0.083 seconds with 23 queries.