ProSoundWeb Community

Please login or register.

Login with username, password and session length
Advanced search  

Pages: [1]   Go Down

Author Topic: Problem with Midas dl 16 snake.  (Read 1384 times)

Ed Jones

  • Newbie
  • *
  • Offline Offline
  • Posts: 5
Problem with Midas dl 16 snake.
« on: July 28, 2017, 08:16:00 pm »

Was running m-32 through aes50 ports to snake. I had no sound. I noticed that the snake box had a bad electrical heat smell.  Of course I already know what that means. Board works fine, no problems running audio on direct outputs. So basically I'm just wondering if anyone else has had this problem with Midas digital snakes.

Ed Jones
Edjones@edwardjonesproductions.com
Logged

Brandon Scopel

  • Full Member
  • ***
  • Offline Offline
  • Posts: 249
Re: Problem with Midas dl 16 snake.
« Reply #1 on: July 28, 2017, 08:17:33 pm »

Was running m-32 through aes50 ports to snake. I had no sound. I noticed that the snake box had a bad electrical heat smell.  Of course I already know what that means. Board works fine, no problems running audio on direct outputs. So basically I'm just wondering if anyone else has had this problem with Midas digital snakes.

Ed Jones
Edjones@edwardjonesproductions.com

Before anyone can respond, you must change the display name to your REAL FIRST AND LAST NAME, thanks
Logged

Ed Jones

  • Newbie
  • *
  • Offline Offline
  • Posts: 5
Re: Problem with Midas dl 16 snake.
« Reply #2 on: July 28, 2017, 10:07:07 pm »

yep already handled. Haven't been on this site for a long while, had to re register . Put my original username from years back. Then seen the rule change. Thanks for the reminder
Logged

Speed Daemon

  • Full Member
  • ***
  • Offline Offline
  • Posts: 110
Re: Problem with Midas dl 16 snake.
« Reply #3 on: July 28, 2017, 10:31:51 pm »

Ed, I can't say that my DL32 has had any problems, but IME the Midas Pro Series stage boxes (with the blue faceplates e.g. DL151) appear to be made to a higher standard of quality. I've had no problems with either, so it's hard to rank them based on no failures in a small sample, but it's at least an option. If your insurance company cuts you a check and you can afford to trade up, that might be an answer for you.
Logged

David Hoover

  • Full Member
  • ***
  • Offline Offline
  • Posts: 168
Re: Problem with Midas dl 16 snake.
« Reply #4 on: July 29, 2017, 08:52:04 am »

Ed, I can't say that my DL32 has had any problems, but IME the Midas Pro Series stage boxes (with the blue faceplates e.g. DL151) appear to be made to a higher standard of quality. I've had no problems with either, so it's hard to rank them based on no failures in a small sample, but it's at least an option. If your insurance company cuts you a check and you can afford to trade up, that might be an answer for you.
We haven't had any issues with our Midas snakes.  They have been reliable.  However, the behringer boxes seem to not enjoy being left on all the time.  We've been having issues with an S16.

Sent from my Nexus 6P using Tapatalk

Logged

ProSoundWeb Community

Re: Problem with Midas dl 16 snake.
« Reply #4 on: July 29, 2017, 08:52:04 am »


Pages: [1]   Go Up
 



Page created in 0.043 seconds with 24 queries.