Sound Reinforcement - Forums for Live Sound Professionals - Your Displayed Name Must Be Your Real Full Name To Post In The Live Sound Forums > Installed Sound/Contracting

Clip light on Crown amps

<< < (3/3)

Mike Diack:
Re spurious clip lights on CTS2k & 3k, there are a few "usual suspects".
1: The 50 way ribbon cable between the input board and the main board - can be verified by wiggling the cable while running signal through the amp and observing what happend.
2: Loose faston connectors on the "tails" from the Lp/Ln chokes. Easily fixed by removing, squishing with pliers, and reconnecting.
3: There is a _|----------|_ shaped bracket under the output filter board tying the grounds together and contacting the case. The old version has a conductive squishy foam doing the case contact, the new version has sharks teeth. Fit the new version. While you're there, verify the tightness of the 8 screws that tie the main board to the output filter board.
4: It could be slightly blown up.
M

Beatpower:

--- Quote from: Lee Buckalew on September 02, 2016, 05:05:33 PM ---Those are all true John, I have also seen the clip indicators light with damaged output sections.  I have seen this repeatedly, on different CTs on the same install. 
CTs were quite awful when they first came out, lots of failures.  This was fixed in the 4 and 8 channel models and the later 2 channels.  Don't know that the stigma of the early problems ever wore off.

Lee

--- End quote ---

@Lee or anyone else, have you seen a CTS with the -20dB LED lit at one of the two channels, while there is nog signal?
It happens frequently, this channel also keeps failing; stops generating sound and after some seconds it comes up again.

What may be wrong?

Mac Kerr:

--- Quote from: Beatpower on March 11, 2024, 06:23:27 AM ---@Lee or anyone else, have you seen a CTS with the -20dB LED lit at one of the two channels, while there is nog signal?
It happens frequently, this channel also keeps failing; stops generating sound and after some seconds it comes up again.

What may be wrong?

--- End quote ---

Please go to your profile and change your displayed o your real full name as required by the posting rules.

Mac
admin

Navigation

[0] Message Index

[*] Previous page

Go to full version