ProSoundWeb Community

Please login or register.

Login with username, password and session length
Advanced search  

Pages: [1]   Go Down

Author Topic: Issue with Yorkvville U15P  (Read 990 times)

Byron Chambers

  • Newbie
  • *
  • Offline Offline
  • Posts: 3
Issue with Yorkvville U15P
« on: August 21, 2016, 12:44:27 pm »

I have a pair of Yorkville U15P's and last night I noticed that one of them had way less high end clarity. I suspected it likely needed the horn replaced so I took it all apart.  The diaphragm of the horn is absolutely perfect, and it still technically works.. as in.. sound comes out of it.  But that still doesn't explain the huge difference between the two boxes.  Any other ideas? Could it still be the horn even though it -looks- healthy?

Thanks.
Logged

Douglas R. Allen

  • Hero Member
  • *****
  • Offline Offline
  • Posts: 1160
Re: Issue with Yorkvville U15P
« Reply #1 on: August 21, 2016, 01:21:51 pm »

It could be the power amp section has a problem. Find an old horn or speaker and connect it and compare it to the "good" speaker.
Douglas R. Allen
Logged

Mike Pyle

  • Hero Member
  • *****
  • Offline Offline
  • Posts: 1014
  • Santa Rosa, CA
Re: Issue with Yorkvville U15P
« Reply #2 on: August 21, 2016, 04:58:53 pm »

Are the three midrange drivers also good?
Logged
Mike Pyle  Audiopyle Sound  707-315-6204
Dealer For: JBL, Soundcraft, Crown, dbx, AKG, Yorkville, EV, QSC, RCF, FBT, Danley Sound Labs, Fulcrum Acoustic, Tannoy, Lab Gruppen, Powersoft, Linea Research, VTC, EAW, Allen & Heath, Ashly, APB, Audix, One Systems, OnPoint Audio, Presonus, K&M, Ultimate, Global Truss, Road Ready, SKB, Gator, Radial Engineering, Turbosound, Midas, dB Technologies, American DJ, Odyssey, ProCo, Rapco, CBI, Elation, Mipro, Chauvet, Blizzard, Shure, Whirlwind, Bassboss, Yamaha, Line 6, Behringer, Whirlwind, On-Stage, more...

Weogo Reed

  • Sr. Member
  • ****
  • Offline Offline
  • Posts: 262
  • Western NC,
    • LiveEdge
Re: Issue with Yorkvville U15P
« Reply #3 on: August 21, 2016, 05:03:28 pm »


 Also check the crossover.


It could be the power amp section has a problem. Find an old horn or speaker and connect it and compare it to the "good" speaker.
Douglas R. Allen
Logged

ProSoundWeb Community

Re: Issue with Yorkvville U15P
« Reply #3 on: August 21, 2016, 05:03:28 pm »


Pages: [1]   Go Up
 



Page created in 0.062 seconds with 24 queries.