ProSoundWeb Community

Please login or register.

Login with username, password and session length
Advanced search  

Pages: [1]   Go Down

Author Topic: Blown 70V system troubleshooting question  (Read 1413 times)

Paul Drenth

  • Newbie
  • *
  • Offline Offline
  • Posts: 22
Blown 70V system troubleshooting question
« on: October 04, 2016, 10:07:54 am »

Here's the System:

Box sale install to a friend for his restaurant. Basic system comprised of (1) Atlas CP400 amp, (6) Lowell OS-100 speakers, and (1) JBL Control 50S/T subwoofer. Speakers were routed through the sub and fed off of one channel of the amp. The other channel used for an outdoor seating zone, (which never got installed). The DSP is a Mini DSP doing basic EQ voicing. This was really low budget...

Here's the problem:

After about 1 year in service, the speakers started popping due to too much bass and level being pumped through them. Upon investigation, I discovered that the speakers were switched to 8ohm mode and NOT any of the 70V taps. The amp was also subsequently wired in bridge mode! I'm surprised it worked as long as it did! Now they want new product to fix the issue. They're not mad, they just want it fixed.

Do you guys suspect this to be a blown amp, blown speakers or both? I don't have the time or resources to go and troubleshoot this properly (with new amp and/or speakers...) What would I test for to make sure they get what they need and not more? Or worse yet, I sell them new speakers and the amp was the culprit...  :o

Thanks in advance.
Logged

Cailen Waddell

  • Hero Member
  • *****
  • Offline Offline
  • Posts: 1427
Re: Blown 70V system troubleshooting question
« Reply #1 on: October 04, 2016, 10:53:43 am »

Here's the System:

Box sale install to a friend for his restaurant. Basic system comprised of (1) Atlas CP400 amp, (6) Lowell OS-100 speakers, and (1) JBL Control 50S/T subwoofer. Speakers were routed through the sub and fed off of one channel of the amp. The other channel used for an outdoor seating zone, (which never got installed). The DSP is a Mini DSP doing basic EQ voicing. This was really low budget...

Here's the problem:

After about 1 year in service, the speakers started popping due to too much bass and level being pumped through them. Upon investigation, I discovered that the speakers were switched to 8ohm mode and NOT any of the 70V taps. The amp was also subsequently wired in bridge mode! I'm surprised it worked as long as it did! Now they want new product to fix the issue. They're not mad, they just want it fixed.

Do you guys suspect this to be a blown amp, blown speakers or both? I don't have the time or resources to go and troubleshoot this properly (with new amp and/or speakers...) What would I test for to make sure they get what they need and not more? Or worse yet, I sell them new speakers and the amp was the culprit...  :o

Thanks in advance.

I would replace both amps and speakers but I would also make it clear that since a number of things were done wrong on the original install, you can make no promises. Really though - if you don't have time to troubleshoot it (and it would hardly be worth the money for how little money is in the system), you don't have any choice. 

I would worry less about your friend.  They tried to get something cheap, screwed t up, and are paying the consequences. 

I don't see how a repair will last unless someone qualified is willing to go replace the amp and speakers, verify the wiring is correct, and verify the equipment is set correctly and make sure the limiters in the mini DSP are also set correctly.

Otherwise this saga is doomed to repeat itself. 


Sent from my iPhone using Tapatalk
Logged

Ivan Beaver

  • Hero Member
  • *****
  • Offline Offline
  • Posts: 8796
  • Atlanta GA
Re: Blown 70V system troubleshooting question
« Reply #2 on: October 04, 2016, 12:41:18 pm »

Tell them they need new speakers and amp.  UNLESS they are willing to pay a good rate to do actual troubleshooting.

If they don't have the knowledge (apparently they don't), then they have to pay the price (all new gear or proper troubleshooting rates).

It is like asking "My car won't start-what do I need to buy".

You could guess, and then guess again and again.

Or you can pay a mechanic to find the problem and fix just that.

Very often being cheap will end up just biting you.
Logged
A complex question is easily answered by a simple-easy to understand WRONG answer!

Ivan Beaver
Danley Sound Labs

PHYSICS- NOT FADS!

John Roberts {JR}

  • Hero Member
  • *****
  • Online Online
  • Posts: 16338
  • Hickory, Mississippi, USA
    • Resotune
Re: Blown 70V system troubleshooting question
« Reply #3 on: October 04, 2016, 01:51:28 pm »

It seems you could answer the amp or speaker bad with one known good speaker and some common sense.

Trying to do installations (or anything) on the cheap will not end well as evidenced. 

JR
Logged
Listen to what a properly "cleared" drum sounds like.   http://circularscience.com/
Pages: [1]   Go Up
 


Page created in 0.037 seconds with 22 queries.