ProSoundWeb Community

Please login or register.

Login with username, password and session length
Advanced search  

Pages: [1]   Go Down

Author Topic: mics not working right  (Read 909 times)

aaroncjones1990

  • Newbie
  • *
  • Offline Offline
  • Posts: 1
mics not working right
« on: November 09, 2015, 01:50:10 pm »

hello I have a Behringer xl2400 mixer and am using 2 Shure 58 betas and 2 shure 87 betas going through it as well as a few guitars. the guitars are going through fine, but the mics are super quiet. I am using the phantom power for the 87 betas not sure what else could be the problem
Logged

Mac Kerr

  • Old enough to know better
  • Administrator
  • Hero Member
  • *****
  • Offline Offline
  • Posts: 6240
  • Audio Plumber
Re: mics not working right
« Reply #1 on: November 09, 2015, 02:26:34 pm »

hello I have a Behringer xl2400 mixer and am using 2 Shure 58 betas and 2 shure 87 betas going through it as well as a few guitars. the guitars are going through fine, but the mics are super quiet. I am using the phantom power for the 87 betas not sure what else could be the problem

How are the input gains set? The 58s, 87s, and guitars will all come to the board at widely different levels, you need to adjust the input trim to get them to the level you need to be able to mix them easily.

Mac
Logged

Jonathan Johnson

  • Hero Member
  • *****
  • Offline Offline
  • Posts: 2908
  • Southwest Washington (state, not DC)
Re: mics not working right
« Reply #2 on: November 10, 2015, 02:08:46 am »

https://www.youtube.com/playlist?list=PL4CF0FA9E71C443FE

Pay attention to video #9, "Guide to Mixing: Setting up a basic mix."

These videos are by Soundcraft, so use Soundcraft equipment, but the concepts presented are valid for all manufacturers' products.
Logged
Stop confusing the issue with facts and logic!
Pages: [1]   Go Up
 


Page created in 0.054 seconds with 24 queries.