ProSoundWeb Community

Please login or register.

Login with username, password and session length
Advanced search  

Pages: [1]   Go Down

Author Topic: PSM 900 Microphonic Antenna  (Read 1824 times)

Tom Hester

  • Jr. Member
  • **
  • Offline Offline
  • Posts: 89
  • Orange County, CA
PSM 900 Microphonic Antenna
« on: October 14, 2014, 09:04:18 pm »

I have 8x PSM900 and on 2 of them I have the same issue. The metal base of the antenna that attaches to the body pack is microphonic, i can clearly hear in my ears when I tap on them. Its not a huge problem or a show stopper, but figured it might be a symptom of something else.

I ordered new antennas to see if that will fix it, has anyone else had this happen?
Logged

John Sulek

  • Sr. Member
  • ****
  • Offline Offline
  • Posts: 383
  • Toronto Canada
Re: PSM 900 Microphonic Antenna
« Reply #1 on: October 14, 2014, 09:22:55 pm »

I have 8x PSM900 and on 2 of them I have the same issue. The metal base of the antenna that attaches to the body pack is microphonic, i can clearly hear in my ears when I tap on them. Its not a huge problem or a show stopper, but figured it might be a symptom of something else.

I ordered new antennas to see if that will fix it, has anyone else had this happen?

Not had this on any psm900 packs, but a few times with psm700 units. We would rotate them back to Shure for service.
On the UR2 mics this is a symptom of the antenna mounting nut being loose causing a less than ideal ground. Might be a similiar issue.

I would speak to the applications engineering folks at Shure. They are very good at troubleshooting over the phone when you need to get it working.
<Product Support at 847-600-8440.>
« Last Edit: October 14, 2014, 09:24:59 pm by John Sulek »
Logged

Scott Helmke

  • Hero Member
  • *****
  • Offline Offline
  • Posts: 1353
Re: PSM 900 Microphonic Antenna
« Reply #2 on: October 15, 2014, 10:23:57 am »

Make sure that the pin on the antenna isn't broken off and stuck in the antenna jack.

Either way it's probably the antenna jack that needs to be resoldered.
Logged

Adam Robinson

  • Hero Member
  • *****
  • Offline Offline
  • Posts: 1162
Re: PSM 900 Microphonic Antenna
« Reply #3 on: October 17, 2014, 12:08:12 pm »

Make sure that the pin on the antenna isn't broken off and stuck in the antenna jack.

Either way it's probably the antenna jack that needs to be resoldered.

I had a one off where about a third of the receivers were microphonic.  Thankfully the sound company supplied the needs for a larger band configuration than we arrived with.  After putting the microphonic units aside, I was left with 0 spares.
Logged

Jim Roach

  • Newbie
  • *
  • Offline Offline
  • Posts: 30
Re: PSM 900 Microphonic Antenna
« Reply #4 on: October 18, 2014, 11:46:06 am »

The second time I used PSM-900's three of the six I had were microphonic, brand new from the factory. To this day I still use RF ear system from another manufacturer.
Logged
Pages: [1]   Go Up
 


Page created in 0.037 seconds with 23 queries.