ProSoundWeb Community

Please login or register.

Login with username, password and session length
Advanced search  

Pages: 1 [2]  All   Go Down

Author Topic: Weird ViSi Remote behavior on Expression 3  (Read 5503 times)

Karen Furno

  • Newbie
  • *
  • Offline Offline
  • Posts: 18
  • Panama City, FL
Re: Weird ViSi Remote behavior on Expression 3
« Reply #10 on: May 06, 2014, 01:59:19 pm »

I just got a response from Richard Morris at Soundcraft - he said there's a glitch in VISI and an update will be released in the next couple of days.
Great news!  Thanks for checking with them.  Now the old software engineer in me wants to know what the glitch is.  It's curious that the iPad Air now has the 64 bit A7 processor.  If ViSi was coded with 32 bit integer math, and if a negative 32 bit value was not properly cast into a 64 bit register, it would turn into a positive number.  I suppose we will never know.  Time to camp out at the App Store, and keep hitting the refresh button...
Logged

Samuel Rees

  • Hero Member
  • *****
  • Offline Offline
  • Posts: 1879
  • Washington, D.C.
Re: Weird ViSi Remote behavior on Expression 3
« Reply #11 on: May 06, 2014, 02:40:11 pm »

These glitches are getting annoying. I stay a feature release behind now, unless there is a bug fix only.
Logged

Karen Furno

  • Newbie
  • *
  • Offline Offline
  • Posts: 18
  • Panama City, FL
Re: Weird ViSi Remote behavior on Expression 3
« Reply #12 on: May 09, 2014, 08:15:11 pm »


RESOLVED.  Soundcraft uploaded a new version (2.0.32) of its ViSi Remote App to the Apple App Store, and it contains a fix to this iPad Air problem.  I downloaded it to my iPad and tried it this evening on our Expression 3.  Works fine, no problems.  Thank you Soundcraft for a timely update.
Logged

ProSoundWeb Community

Re: Weird ViSi Remote behavior on Expression 3
« Reply #12 on: May 09, 2014, 08:15:11 pm »


Pages: 1 [2]  All   Go Up
 



Page created in 0.051 seconds with 23 queries.