ProSoundWeb Community

Please login or register.

Login with username, password and session length
Advanced search  

Pages: 1 2 [3]  All   Go Down

Author Topic: Fader issue on a Presonus 16.4.2  (Read 12260 times)

Tim Perry

  • Hero Member
  • *****
  • Offline Offline
  • Posts: 1251
  • Utica-Rome NY
Re: Fader issue on a Presonus 16.4.2
« Reply #20 on: September 26, 2013, 11:04:19 pm »

You know, using the iPad app, I have barely touched my faders on my SL in the last year!  When I have, they seemed to feel pretty good compared to what I have used in the past.  I'm not really worried about it.

No problem with faders here.  I even survived a very wet outdoor summer season.
Logged

Jonathan Goodall

  • Sr. Member
  • ****
  • Offline Offline
  • Posts: 484
  • New Zealand
Re: Fader issue on a Presonus 16.4.2
« Reply #21 on: September 26, 2013, 11:16:05 pm »

Assuming the SL has been bought from Oceania, Nigel will source the faders and I will fit them.
Even though the unit is out of warranty, the parts and labour cost is not huge (SOMETHING had to be compromised making a mixer with these features for not much money). Rare is the week I don't have an SL in the workshop for new faders. BTW you can fit Alps "K" series faders into these things and they will last forever.

I sent Nigel an email not long ago lol.
I checked  all of the others as requested and only the one seems to have any issues.   I did try running some low pressure air over it (as suggested, no cleaner) and the problem is not now as bad as it was, but not cured either (still jitters around on UC but will track with the fader to certain extent).
Logged

Bob Leonard

  • Hero Member
  • *****
  • Offline Offline
  • Posts: 6807
  • Boston, MA USA
Re: Fader issue on a Presonus 16.4.2
« Reply #22 on: September 27, 2013, 10:40:08 am »

I sent Nigel an email not long ago lol.
I checked  all of the others as requested and only the one seems to have any issues.   I did try running some low pressure air over it (as suggested, no cleaner) and the problem is not now as bad as it was, but not cured either (still jitters around on UC but will track with the fader to certain extent).

If your sure it's bad it won't hurt to try some cleaner and the vac as I mentioned above.
Logged
BOSTON STRONG........
Proud Vietnam Veteran

I did a gig for Otis Elevator once. Like every job, it had it's ups and downs.

ProSoundWeb Community

Re: Fader issue on a Presonus 16.4.2
« Reply #22 on: September 27, 2013, 10:40:08 am »


Pages: 1 2 [3]  All   Go Up
 



Page created in 0.035 seconds with 25 queries.