ProSoundWeb Community

Please login or register.

Login with username, password and session length
Advanced search  

Pages: [1]   Go Down

Author Topic: Powered Speaker Amp Module Limit Issues  (Read 1948 times)

Joshua W. Hatton

  • Newbie
  • *
  • Offline Offline
  • Posts: 5
Powered Speaker Amp Module Limit Issues
« on: September 21, 2013, 04:53:24 pm »

OK Guys... I have a couple of Mackie SA 1232 (non-"Z") amp modules that are limiting their cabinets before they 'really' should kick in. Please don't give me the "This is a 'Pro Forum' ... Mackie is not Pro" spill or anything... just help a guy out if you can, please?

I have removed the modules from the cabinets, and performed some preliminary bench testing. There is correct load on each speaker component... 16 ohm, 8 ohm respectively, so the speakers are fine. I make me some jumpers to go between the speaker wiring harness, and the speaker terminals on-board the amp module. First thing I realize, even before connecting the speakers back to the amp terminals, I notice there is a component (or possibly two) that is 'chattering' when the limiting circuit kicks in. There are two of these components marked "Mackie ME 190 304" .  When running, one is slightly warm, the other is cool to the touch. What is this component? What do I need to do to get these units optimum again?

I am an electronics technician, but I don't know what this is to begin a true repair!

Thanks for any help.

Photo of component attached.
Logged

John Roberts {JR}

  • Hero Member
  • *****
  • Offline Offline
  • Posts: 16643
  • Hickory, Mississippi, USA
    • Resotune
Re: Powered Speaker Amp Module Limit Issues
« Reply #1 on: September 21, 2013, 05:49:02 pm »

Have you considered asking Mackie Service?

JR
Logged
When in doubt do what's right.

ProSoundWeb Community

Re: Powered Speaker Amp Module Limit Issues
« Reply #1 on: September 21, 2013, 05:49:02 pm »


Pages: [1]   Go Up
 



Page created in 0.046 seconds with 22 queries.