ProSoundWeb Community

Please login or register.

Login with username, password and session length
Advanced search  

Pages: 1 2 3 [All]   Go Down

Author Topic: My first sub alignment using Smaart  (Read 15412 times)

Mark McFarlane

  • Hero Member
  • *****
  • Offline Offline
  • Posts: 1865
  • Middle East
    • Arkose Records
My first sub alignment using Smaart
« on: August 02, 2012, 02:22:29 pm »

Following the procedure I posted 2 days ago, I took to the outdoors today for my first measurements.  It was in the mid 110's at sunset. Worked from sunset for about 3 hours. Dripping wet humidity, so I guess I'll need to remeasure on a dryer day.

Measurement mic is a calibrated Audix TM-1 going through a Motu 896mk3. Console is an 01V96v2.  Speaker processinfg by Sabine NAV4802.

First plot is ambient noise. Lots of AC's running in the neighborhood, the size of Volkswagen Beatles, probably a dozen picked up by the mic... 113Hz is probably the predominant AC noise.

Next plot is at the end of the session.  Two new RCF TT22A tops with no Eq or filters, I'm not too happy about the amplitude response from 800-2500,... polarity problem? humidity? measurement error? Anyway, it shouldn't effect the sub aligment.

Third plot is a capture of the tops early in the session, and again about 3 hours later, well after sunset. I'm not sure if the changing humidity did this or if I had some processing going, but I'm 99% sure the signal chain was indentical for both, except the mic distance was probably changed and the temp had dropped maybe 20F but the humidity feels like it went up.
« Last Edit: August 02, 2012, 03:06:43 pm by Mark McFarlane »
Logged
Mark McFarlane
ARKOSERECORDS
Turn down what's too loud.

Mark McFarlane

  • Hero Member
  • *****
  • Offline Offline
  • Posts: 1865
  • Middle East
    • Arkose Records
Re: My first sub alignment using Smaart
« Reply #1 on: August 02, 2012, 02:34:59 pm »

First plot is the processing for an RCF 905AS sub (some EQ applied and 31Hz HPF & 110Hz LPF).  Second plot is the subs response.

Third plot is the processing for the tops (84Hz HPF).  Fourth plot is the repsonse for the tops, with 5.771ms delay applied in the Sabine NAV4080.

I ended up with fairly gently sloping Butterworth filters, they seemd to have the phase repsonse that got me the best alignment. I tried LR, Bessel, and Butterworth filter types, many slopes, different corner frequencies,..
« Last Edit: August 02, 2012, 03:10:15 pm by Mark McFarlane »
Logged
Mark McFarlane
ARKOSERECORDS
Turn down what's too loud.

Mark McFarlane

  • Hero Member
  • *****
  • Offline Offline
  • Posts: 1865
  • Middle East
    • Arkose Records
Re: My first sub aligment using Smaart
« Reply #2 on: August 02, 2012, 02:42:23 pm »

Here's a plot of the raw sub with no corective EQ. Looks like a one note wonder.

The second plot shows a comparison before and after corective EQ and HPF/LPF.

I made no attempt to keep the gain or volume the same for any of these plots, I just slid the 2 sub plots up and down so they were easier to see..

Edit: I added in the manufacturers spec on the subs.  It also shows a peak around 70Hz.
« Last Edit: August 02, 2012, 03:46:34 pm by Mark McFarlane »
Logged
Mark McFarlane
ARKOSERECORDS
Turn down what's too loud.

Mark McFarlane

  • Hero Member
  • *****
  • Offline Offline
  • Posts: 1865
  • Middle East
    • Arkose Records
Re: My first sub aligment using Smaart
« Reply #3 on: August 02, 2012, 02:50:22 pm »

The next plot is the final system response with crossovers applied, corrective EQ for the sub, and a 5.771ms delay applied to the tops.

A few observations:
The selection of the crossover cutoffs and slopes had a big impact on the phase, the corrective EQ less so (small corrections +/- 3.7db)

I probably should have spent a little more time working on the phase alignment from 70-120, the acoustic crossover.  I might have been able to get this a few degrees closer.

I think I got a decent result, we'll see what the pros say.  Unfortunately I couldn't crank the system and listen much, just a few seconds and it sounded good.

« Last Edit: August 02, 2012, 03:13:48 pm by Mark McFarlane »
Logged
Mark McFarlane
ARKOSERECORDS
Turn down what's too loud.

Tim McCulloch

  • SR Forums
  • Hero Member
  • *
  • Offline Offline
  • Posts: 21372
  • Wichita, Kansas USA
Re: My first sub aligment using Smaart
« Reply #4 on: August 02, 2012, 02:55:37 pm »

Following the procedure I posted 2 days ago, I took to the outdoors today for my first measurements.  It was in the mid 110's at sunset. Worked from sunset for about 3 hours. Dripping wet humidity, so I guess I'll need to remeasure on a dryer day.

Measurement mic is a calibrated Audix TM-1 going through a Motu 896mk3. Console is an 01V96v2.  Speaker processinfg by Sabine NAV4802.

First plot is ambient noise. Lots of AC's running in the neighborhood, the size of Volkswagen Beatles, probably a dozen picked up by the mic...

Next plot is at the end of the session.  Two new RCF TT22A tops with no Eq or filters, I'm not too happy about the amplitude response from 800-2500,... polarity problem? humidity? measurement error? Anyway, it shouldn't effect the sub aligment.

Third plot is a capture of the tops early in the session, and again about 3 hours later, well after sunset. I'm not sure if the changing humidity did this or if I had some processing going, but I'm 99% sure the signal chain was indentical for both, except the mic distance was probably changed and the temp had dropped maybe 20F but the humidity feels like it went up.

The big dip in the magnitude response correlates with a big dip in the coherence trace.  This is usually an indication there is a very strong reflection getting into your measurement.  If you saved the reference and measurement audio as wav files, you can go back and run it again; look at the impulse response and see if there is a really big peak a millisecond or so after the initial impulse arrival.
Logged
"Practicing an art, no matter how well or badly, is a way to make your soul grow, for heaven's sake. Sing in the shower. Dance to the radio. Tell stories. Write a poem to a friend, even a lousy poem. Do it as well as you possible can. You will get an enormous reward. You will have created something."  - Kurt Vonnegut

Mark McFarlane

  • Hero Member
  • *****
  • Offline Offline
  • Posts: 1865
  • Middle East
    • Arkose Records
Re: My first sub alignment using Smaart
« Reply #5 on: August 02, 2012, 03:28:57 pm »

The big dip in the magnitude response correlates with a big dip in the coherence trace.  This is usually an indication there is a very strong reflection getting into your measurement.  If you saved the reference and measurement audio as wav files, you can go back and run it again; look at the impulse response and see if there is a really big peak a millisecond or so after the initial impulse arrival.

Thanks Tim for the help.  I hope its a reflection problem.  Maybe tomorrow night I'll turn the speakers the other way so there's nothing in front of them. Setting up was a PITA, but my system is near the garage tonight.  Is a good way to test the tops by themselves with the tops on the ground and the mic touching the ground at 45 degrees?

Below are pics of the physical setup.  I just realized the car wasn't there all night so that's probably part of the reason the response changed over the night.  The tree might be another source.  I'm space challenged, I basically have no yard.  I didn't save the wave files, didn't know that was an option.  Note my measurements are from using the transfer function, not an impulse response.

I also ran these tests with the fronts of sub and top vertically aligned to prevent any interference in the cabs.  For a show, if I ground stack, I may use a 10" pole and pole mount the tops for stability, which will push the tops back 8 inches or so which I can correct for.  The tops don't have any feet so I suspect they would dance off the subs without strapping or using a 'tiny pole'.  More likely my actual gigs will use tall poles, or centered clustered subs, but I had to start the measurements somewhere.
« Last Edit: August 02, 2012, 03:40:28 pm by Mark McFarlane »
Logged
Mark McFarlane
ARKOSERECORDS
Turn down what's too loud.

Mark McFarlane

  • Hero Member
  • *****
  • Offline Offline
  • Posts: 1865
  • Middle East
    • Arkose Records
Re: My first sub alignment using Smaart
« Reply #6 on: August 02, 2012, 03:52:28 pm »

The big dip in the magnitude response correlates with a big dip in the coherence trace.  This is usually an indication there is a very strong reflection getting into your measurement.  If you saved the reference and measurement audio as wav files, you can go back and run it again; look at the impulse response and see if there is a really big peak a millisecond or so after the initial impulse arrival.

Also, note on the graph below showing the 2 different TT22A speakers, test made near the end of the night (I think the parked car was gone when I made these measurements), that there is still a dip around 1.8K and the coherence is stable.  The TT22A spec sheet says the electronic xover is 1.2KHz.  Looking at the spec sheet, and considering my mic is only about 10' from the cabinets, I think the response I am seeing around 1.5K may partly due to the off-axis response, the horn of the top is probably 4' off the ground.  However, the expected response is a peak around 1.8K, not a trough..., strange
« Last Edit: August 02, 2012, 04:06:26 pm by Mark McFarlane »
Logged
Mark McFarlane
ARKOSERECORDS
Turn down what's too loud.

Dave Jones

  • Newbie
  • *
  • Offline Offline
  • Posts: 12
Re: My first sub alignment using Smaart
« Reply #7 on: August 02, 2012, 10:27:40 pm »

Thanks for posting this.

It's a very interesting read.

Regards,

Dj
Logged

Paul Tucci

  • SR Forums
  • Sr. Member
  • *
  • Offline Offline
  • Posts: 371
Re: My first sub alignment using Smaart
« Reply #8 on: August 02, 2012, 10:37:44 pm »

First plot is ambient noise. Lots of AC's running in the neighborhood, the size of Volkswagen Beatles, probably a dozen picked up by the mic... 113Hz is probably the predominant AC noise.


Mark,

I view the first plot as a meaningless measurement, not ambient noise.
 
Here's my thinking. What you wanted was to show the spectral content of the ambient environment.
You're asking the question " What's the frequency content of an open mic look like?"

 That dictates a single channel measurement in spectrum mode. It is not a comparison measurement, it's a straight up single channel observation of the spectral content. PERFECT for an RTA. We would see amplitude vs frequency.

What the screenshot shows is a classic bad measurement. There are clues to understand that.
Firstly, it's a two channel measurement. Those measurements attempt to answer the question "What's the relative difference
between these two sources in the frequency domain?" In other words, the measurement signal might have more high frequency content than the reference signal. It's useful to think of these two channels as before and after. After going through the device, what happens?
Secondly, the phase trace sucks. I suggest taking a hundred measurements and really understand what a perfect measurement looks like. Flat lines in the amplitude and phase axis. ZERO CHANGE. We need an area of flat phase trace to be assured that the signals are properly synchronized. Without it, useless.
Thirdly, the Coherence sucks. Another indication of a bad measurement.

The Transfer Function measurement was the wrong place to start because you're not making a comparison. You wanted raw data. "What's going on in the local environment acoustically?" One channel answers that question.

I believe the measurement you made asked the question "Whats the difference between these two signals in the frequency domain?" EXCEPT that theres only one channel of signal, the open mic in situ. The second channel is needed for a comparison. It's like dividing by zero mathematically. You can't.

Offered up in support, not trying to blow your buzz.
I am so thankful to Dr Don, Jamie, 6O6, Sam, Paul Bauman and others for rooting my limited understanding of this stuff.

PT
Logged

Paul Tucci

  • SR Forums
  • Sr. Member
  • *
  • Offline Offline
  • Posts: 371
Re: My first sub alignment using Smaart
« Reply #9 on: August 03, 2012, 08:48:54 am »

See if this stuff from my archive helps.
« Last Edit: August 03, 2012, 09:39:27 am by Paul Tucci »
Logged

Paul Tucci

  • SR Forums
  • Sr. Member
  • *
  • Offline Offline
  • Posts: 371
Re: My first sub alignment using Smaart
« Reply #10 on: August 03, 2012, 09:40:00 am »

See if this stuff from my archive helps.
Logged

Paul Tucci

  • SR Forums
  • Sr. Member
  • *
  • Offline Offline
  • Posts: 371
Re: My first sub alignment using Smaart
« Reply #11 on: August 03, 2012, 09:40:58 am »

See if this stuff from my archive helps.
Logged

Paul Tucci

  • SR Forums
  • Sr. Member
  • *
  • Offline Offline
  • Posts: 371
Re: My first sub alignment using Smaart
« Reply #12 on: August 03, 2012, 09:43:04 am »

Logged

Paul Tucci

  • SR Forums
  • Sr. Member
  • *
  • Offline Offline
  • Posts: 371
Re: My first sub alignment using Smaart
« Reply #13 on: August 03, 2012, 09:44:18 am »

Logged

Paul Tucci

  • SR Forums
  • Sr. Member
  • *
  • Offline Offline
  • Posts: 371
Re: My first sub alignment using Smaart
« Reply #14 on: August 03, 2012, 03:33:02 pm »

Mark,

Clearly you are on the right track. I'll offer up comments to those learning from the discussion.
The screenshots that follow help explain why just pushing the Auto SM button may not be as easy as it sounds.

PT
Logged

Paul Tucci

  • SR Forums
  • Sr. Member
  • *
  • Offline Offline
  • Posts: 371
Re: My first sub alignment using Smaart
« Reply #15 on: August 03, 2012, 03:34:06 pm »

Continued...
Logged

Paul Tucci

  • SR Forums
  • Sr. Member
  • *
  • Offline Offline
  • Posts: 371
Re: My first sub alignment using Smaart
« Reply #16 on: August 03, 2012, 03:34:56 pm »

Continued
Logged

Mark McFarlane

  • Hero Member
  • *****
  • Offline Offline
  • Posts: 1865
  • Middle East
    • Arkose Records
Re: My first sub alignment using Smaart
« Reply #17 on: August 03, 2012, 03:42:37 pm »

Mark,

Clearly you are on the right track. I'll offer up comments to those learning from the discussion.
The screenshots that follow help explain why just pushing the Auto SM button may not be as easy as it sounds.

PT

Lets just ignore the ambient noise graph, shall we.  I understand I should have used the Spectrum display.

Perhaps this thread is getting off track.  What about the actual system alignment I posted? 

FWIW, I didn't use the auto delay detection, I did it manually.
Logged
Mark McFarlane
ARKOSERECORDS
Turn down what's too loud.

Paul Tucci

  • SR Forums
  • Sr. Member
  • *
  • Offline Offline
  • Posts: 371
Re: My first sub alignment using Smaart
« Reply #18 on: August 03, 2012, 05:10:04 pm »

Lets just ignore the ambient noise graph, shall we. ?

Although the comment was back to you, the real audience, I feel, is always the many readers who are learning things but not commenting. My point was for their benefit, hence the directness. No need to feel attacked.
Yes, we'll get to comments about your alignment. Clearly, you're fluent in the language.

PT
Logged

Kent Thompson

  • Sr. Member
  • ****
  • Offline Offline
  • Posts: 293
Re: My first sub alignment using Smaart
« Reply #19 on: August 04, 2012, 03:03:03 pm »

Although the comment was back to you, the real audience, I feel, is always the many readers who are learning things but not commenting. My point was for their benefit, hence the directness. No need to feel attacked.
Yes, we'll get to comments about your alignment. Clearly, you're fluent in the language.

PT

Thank you! You reminded me of something said during a training class I took but, forgot.
Logged

Mark McFarlane

  • Hero Member
  • *****
  • Offline Offline
  • Posts: 1865
  • Middle East
    • Arkose Records
Re: My first sub alignment using Smaart
« Reply #20 on: August 06, 2012, 03:14:23 pm »

Mark, I view the first plot as a meaningless measurement, not ambient noise....

As it turns out, my ambient noise plot really isn't that bad. I certainly wouldn't recommend someone using a transfer function instead of a spectrum plot, but since my reference trace was in this case esentially random electronic digitl console noise, the transfer fuctions magnitude plot itself isn't that far from a single channel spectrum plot. 

The trick here is that my refernce trace was essentially white.

Below is a comparison of using atransfer function versus a spectrum plot for measuring the ambient noise in my garage.  The major events, like the fan noise at 56Hz, are basically the same on both plots.

One can try this experiment at home.

Again, I don't recomend using the transfer function to measure what should be a single channel spectrum measurement, but if your reference trace is low level white-ish noise the results won't be too far off, the math works fine.

Anyway, back on track, anyone have a comment on the system alignment?
Logged
Mark McFarlane
ARKOSERECORDS
Turn down what's too loud.

Paul Tucci

  • SR Forums
  • Sr. Member
  • *
  • Offline Offline
  • Posts: 371
Re: My first sub alignment using Smaart
« Reply #21 on: August 06, 2012, 09:51:26 pm »

As it turns out, my ambient noise plot really isn't that bad. I certainly wouldn't recommend someone using a transfer function instead of a spectrum plot, but since my reference trace was in this case esentially random electronic digitl console noise, the transfer fuctions magnitude plot itself isn't that far from a single channel spectrum plot. 


Mark,

As I stated previously, I don't recommend using a TF measurement for what is a single channel measurement either, but if you do, I highly recommend using the Magnitude Threshold parameter option during a TF measurement so that no resultant display is given if there is no valid Reference signal. Proper technique trumps blind luck in this endeavor.  I trust that was illustrated by the previous posts.

Paul
Logged

Rasmus Rosenberg

  • Jr. Member
  • **
  • Offline Offline
  • Posts: 55
Re: My first sub alignment using Smaart
« Reply #22 on: August 09, 2012, 06:42:04 am »

Mark,

As I stated previously, I don't recommend using a TF measurement for what is a single channel measurement either, but if you do, I highly recommend using the Magnitude Threshold parameter option during a TF measurement so that no resultant display is given if there is no valid Reference signal. Proper technique trumps blind luck in this endeavor.  I trust that was illustrated by the previous posts.

Paul

Paul,
When you have time it would be nice with a post about background noise and how to measure it and how to relate to it (how to try to exclude/include it from measurement etc). If Dough would chime in with the Systune feature it would be nice too. There seems to pop up quite a few questions about it. Where people hired to look at a speaker installation also gets tasked to analyze background noise/ fan noise etc. But most importantly proberly how to measure and and relate to how much a venue "spills" to its neighbours out side, upside, downside etc. I know a big task with a can of worms, but im sure you and others know how to do it, or at least has a priotity list :)   
Logged

Doug Fowler

  • Member since May 1995, 2nd poster on original LAB, moderator on and off since 1997, now running TurboMOD v1.826
  • Administrator
  • Hero Member
  • *****
  • Offline Offline
  • Posts: 1769
  • Saint Louis, MO USA
Re: My first sub alignment using Smaart
« Reply #23 on: August 10, 2012, 10:03:00 pm »

Paul,
When you have time it would be nice with a post about background noise and how to measure it and how to relate to it (how to try to exclude/include it from measurement etc). If Dough would chime in with the Systune feature it would be nice too. There seems to pop up quite a few questions about it. Where people hired to look at a speaker installation also gets tasked to analyze background noise/ fan noise etc. But most importantly proberly how to measure and and relate to how much a venue "spills" to its neighbours out side, upside, downside etc. I know a big task with a can of worms, but im sure you and others know how to do it, or at least has a priotity list :)

SSA Filter demonstration video:

http://www.youtube.com/watch?v=UiEZ7lnShrA&feature=youtube_gdata_player



Logged
"It's got electrolytes.  It's got what plants crave."

ProSoundWeb Community

Re: My first sub alignment using Smaart
« Reply #23 on: August 10, 2012, 10:03:00 pm »


Pages: 1 2 3 [All]   Go Up
 



Page created in 0.031 seconds with 22 queries.