ProSoundWeb Community

Please login or register.

Login with username, password and session length
Advanced search  

Pages: 1 2 [3] 4   Go Down

Author Topic: DSR 112 failure  (Read 2441 times)

Mike Karseboom

  • Full Member
  • ***
  • Offline Offline
  • Posts: 193
Re: DSR 112 failure
« Reply #20 on: September 07, 2017, 05:38:52 pm »

I had both of my DSR112's fail last weekend when used as mains over srx718 subs for a band at an outdoor wedding.  They were being driven fairly hard for a party of 120 or so but crossed over at 100Hz and not clipping.  No direct sun but the temp was around 90F.


Both boxes shut themselves off during the last 1/2 hour, after about 3 hours of continuous use.  They did not seem overly hot and smelled OK but maybe it was thermal protection.  They came back to life after turning them off and on.  Unfortunately one of them continued to go off and after successively shorter periods of coming back to life, it would not stay on at all. 


The other one stayed on the rest of the gig.  But the next day it started crackling and distorting when being used as a monitor.  I had this same problem with the same box last year and sent it in for repair.  The repair notes were somewhat obtuse and referenced some plate being tightened.


Having a need  for these boxes for a festival starting tomorrow I  thought I would at do an internal inspection of the drivers and electronics.  The drivers looked and felt good and sounded OK when driven from a conventional amp. 


I could not see anything burned or loose in the plate amp but did note these feature ribbon cables between the input block and the main amp block.  Ribbon cables have been a source of problems for me in the past with an old Mackie 1604 mixer and with my DR260 processors.  And, sure enough, cleaning and re-seating the ribbon cables completely fixed the distorting box and brought the dead box back to life except no woofer.


Additional disassembly and  tinkering with the box with the non-functional woofer exposed a somewhat unusual rigid multi-pin pass-through connector between the 3 circuit boards in the input block.  After pulling this apart and putting it back together to re-seat / clean it, the woofer came back to life. Yeah!


Now both boxes seem to be working 100% again.  My conclusion is that the ribbon cable connections and rigid multi-pin connectors can exhibit bad connectivity after some time in use.  I suppose this is the result of the constant vibration they must endure. 


I drive the boxes hard  when used as mains and this may exacerbate the problem.  I don't drive them into clipping and don't feel like I abuse these speakers.  Rather, I am of the opinion that the design of the connectors is weak.  I have K12's, PRX615's, and PRX712's that have been driven just as hard for more years of use and none of them have failed in any way.


I love the sound of the DSR112 but when I add these 3 separate failures to my list of complaints about the physical packaging, the love affair is becoming a bit tarnished.  I don't think I will be buying any more of these.
Logged
--Mike
"If you're not confused, you don't know what is going on"

Live Sound for the Mt. Shasta area
http://www.shastalivesound.com

Wayne Smith2

  • Jr. Member
  • **
  • Offline Offline
  • Posts: 56
Re: DSR 112 failure
« Reply #21 on: September 07, 2017, 06:45:41 pm »

Owner, subscribing to follow

..Just to add, so many 'years, incidents of the 'mackie ribbon cr*p, ears perked up a bit here.
« Last Edit: September 07, 2017, 06:50:30 pm by Wayne Smith2 »
Logged

Jay Marr

  • Sr. Member
  • ****
  • Offline Offline
  • Posts: 325
Re: DSR 112 failure
« Reply #22 on: September 08, 2017, 09:47:58 am »


I could not see anything burned or loose in the plate amp but did note these feature ribbon cables between the input block and the main amp block.  Ribbon cables have been a source of problems for me in the past with an old Mackie 1604 mixer and with my DR260 processors.  And, sure enough, cleaning and re-seating the ribbon cables completely fixed the distorting box and brought the dead box back to life except no woofer.


Additional disassembly and  tinkering with the box with the non-functional woofer exposed a somewhat unusual rigid multi-pin pass-through connector between the 3 circuit boards in the input block.  After pulling this apart and putting it back together to re-seat / clean it, the woofer came back to life. Yeah!


Thanks, this is super helpful for troubleshooting if one fails on me (I just bought a set of these).
Logged

Bradford "BJ" James

  • Full Member
  • ***
  • Offline Offline
  • Posts: 142
Re: DSR 112 failure
« Reply #23 on: September 08, 2017, 12:49:38 pm »

Just so no one panics over this, I've owned several dozen of these over the past few years. The only failure I've had has been recently when I noticed one starting to fizz and sputter a bit when out in the sun all day. It always worked fine at the shop afterwards so it took a while to troubleshoot but I finally started to notice a pattern. Anyways, Yamaha was aware of the problem, had me send the unit back and had it back to me by the end of that week. Working 100%. Yamaha service rocks if you do ever have issues.
Logged

Bob Leonard

  • Hero Member
  • *****
  • Offline Offline
  • Posts: 6317
  • Boston, MA USA
Re: DSR 112 failure
« Reply #24 on: September 08, 2017, 04:42:04 pm »

That makes me think of PSU failure, but it could be any of several things.  Since it's all on 1 board I don't imagine there is any other fast repair.

One thread and a dozen failed cabinets? WTF, over.
Logged
BOSTON STRONG........

I did a gig for Otis Elevator once. Like every job, it had it's ups and downs.

Tim McCulloch

  • SR Forums
  • Hero Member
  • *
  • Offline Offline
  • Posts: 17377
  • Wichita, Kansas USA
Re: DSR 112 failure
« Reply #25 on: September 08, 2017, 05:04:39 pm »

One thread and a dozen failed cabinets? WTF, over.

So for Mike K, it turns out to be ribbon cables and thru-board terminations that are oxidizing.  I'm batting 000 on this one.

I'd not be so quick to judge the DSR to be some kind of failure.  Like the X32, there are multi-bunches of these out in the wild and we hear almost exclusively from those who've had a failure.  Mike's investigation (probably not done by the service center, as they're paid by unit and not by hour) indicates this is also possibly environmental and/or age related and not a fatal design flaw.

Anyone who really doesn't want their DSR speakers any more can send them to me, I'll give them a good home.
Logged
"Practicing an art, no matter how well or badly, is a way to make your soul grow, for heaven's sake. Sing in the shower. Dance to the radio. Tell stories. Write a poem to a friend, even a lousy poem. Do it as well as you possible can. You will get an enormous reward. You will have created something."  - Kurt Vonnegut

Kemper Watson

  • Sr. Member
  • ****
  • Offline Offline
  • Posts: 319
Re: DSR 112 failure
« Reply #26 on: September 08, 2017, 06:13:29 pm »

So for Mike K, it turns out to be ribbon cables and thru-board terminations that are oxidizing.  I'm batting 000 on this one.

I'd not be so quick to judge the DSR to be some kind of failure.  Like the X32, there are multi-bunches of these out in the wild and we hear almost exclusively from those who've had a failure.  Mike's investigation (probably not done by the service center, as they're paid by unit and not by hour) indicates this is also possibly environmental and/or age related and not a fatal design flaw.

Anyone who really doesn't want their DSR speakers any more can send them to me, I'll give them a good home.

   Yep, no one complains about a working speaker. These things sound really good. Think I'll keep mine.
Logged

Scott Bolt

  • Hero Member
  • *****
  • Offline Offline
  • Posts: 1139
Re: DSR 112 failure
« Reply #27 on: September 08, 2017, 06:34:46 pm »

Mike,

As a DSR112 owner, I thank you for the information.  It may become useful for me some day.

My 7 year warranty will be up this fall.  I have lugged my speakers in the rain, ran them outdoors hard, and use them weekly.  At least my 2 have performed flawlessly.

I did have a TC Electronics M-One XL that started getting glitchy on me after 10 years of service.  Same problem (oxidized ribbon connection).

I am with Tim on this one.  If you want a home for them, I have plenty of room in my home for another pair ;)

I can see an oxidized ribbon cable being an issue after lots of use .... especially in humid conditions.  Considering how hard these speakers hit in the 90-120Hz range, I can see things getting a good rattling over the life of the speaker.

My old MixWiz also suffered from a ribbon cable connection problem.  For those people who have been doing this stuff for a while, ribbon cable connections are a prime suspect in any aged electronics gear that has been exposed to vibration and humidity.  Usually a little contact cleaner on the pins and a couple of insertions and removals is enough to put things back to working order.

Has anyone tried conductive grease in situations like this?  I was thinking that it might prevent corrosion and keep the contact on the pins even in the presence of lots of vibration.  Perhaps a little hot glue to secure the connector in place?

Another plus for these speakers is that even after 7 years of service, they look like brand new.  The surface treatment on these speakers is really fantastic.
Logged

Dave Garoutte

  • Hero Member
  • *****
  • Offline Offline
  • Posts: 570
  • San Rafael, CA
Re: DSR 112 failure
« Reply #28 on: September 08, 2017, 07:02:29 pm »

I was starting to get worried! :o

Logged
Events. 
Stage, PA, Lighting and Backline rentals.
Chauvet dealer.
Inventor.

Debbie Dunkley

  • Hero Member
  • *****
  • Offline Offline
  • Posts: 3189
  • Central North Carolina
Re: DSR 112 failure
« Reply #29 on: September 08, 2017, 07:49:07 pm »

No-one's getting mine!!!
Logged
A young child says to his mother, "Mom, when I grow up I'm going to be a musician." She replies, "Well honey, you know you can't do both."
Pages: 1 2 [3] 4   Go Up
 


Page created in 0.115 seconds with 18 queries.