ProSoundWeb Community

Please login or register.

Login with username, password and session length
Advanced search  

Pages: [1] 2 3 ... 9   Go Down

Author Topic: Dante recording has spikes (& simple Dante setup discussion)  (Read 4033 times)

Mark McFarlane

  • Hero Member
  • *****
  • Offline Offline
  • Posts: 1508
  • Middle East
    • Arkose Records
Dante recording has spikes (& simple Dante setup discussion)
« on: March 03, 2014, 03:18:48 pm »

I finally got around to trying recording via Dante on my new A&H GLD 112.


Set up static addresses on both the Dante card and MacBook Pro (OSX 10.9.1, 2.8 GHz Intel Core 2 Duo, i.e. old laptop). 10.0.1.x
Set up Dante for 32*32.
Set DVS to 10ms latency (highest setting). Set Cubase to use a 2048 sample buffer (highest setting).
Turned off wifi on the MacBook Pro.
No network, just a normal cat 5 cable between MacBook Pro and Dante primary port on option card.
GLD control network isn't hooked up to anything.
Dante Controller (latest version downloaded tonight) says all is well. GB connection, no errors, no log errors, IP addresses are cool, everything routes just fine...


Tried recording 10 tracks in Reaper, and 24 tracks in Cubase, and I get the same problem, random spikes across random tracks.  Cubase has an option for 'external clock' which I selected and deselected, it made no difference.


FWIW, recording works flawlessly on my new X32 via USB on the same system.


Any ideas what my problem might be?


« Last Edit: March 12, 2014, 04:59:45 am by Mark McFarlane »
Logged
Mark McFarlane
ARKOSERECORDS
Turn down what's too loud.

David Shriver

  • Jr. Member
  • **
  • Offline Offline
  • Posts: 76
    • Rockport Music
Re: Dante recording has spikes
« Reply #1 on: March 03, 2014, 05:02:59 pm »

Hi Mark,

I use a Dante in my A&H iLive from time to time.  I've found the best stability with setting the iLive system clock master to be the Dante card.  Make the Dante card the master for your GLD and for your computer.  I don't know that is your problem, but at least for me it offered the best stability.

-d

I finally got around to trying recording via Dante on my new A&H GLD 112.


Set up static addresses on both the Dante card and MacBook Pro (OSX 10.9.1, 2.8 GHz Intel Core 2 Duo, i.e. old laptop). 10.0.1.x
Set up Dante for 32*32.
Set DVS to 10ms latency (highest setting). Set Cubase to use a 2048 sample buffer (highest setting).
Turned off wifi on the MacBook Pro.
No network, just a normal cat 5 cable between MacBook Pro and Dante primary port on option card.
GLD control network isn't hooked up to anything.
Dante Controller (latest version downloaded tonight) says all is well. GB connection, no errors, no log errors, IP addresses are cool, everything routes just fine...


Tried recording 10 tracks in Reaper, and 24 tracks in Cubase, and I get the same problem, random spikes across random tracks.  Cubase has an option for 'external clock' which I selected and deselected, it made no difference.


FWIW, recording works flawlessly on my new X32 via USB on the same system.


Any ideas what my problem might be?
Logged

Alan R Roberts

  • Newbie
  • *
  • Offline Offline
  • Posts: 21
Re: Dante recording has spikes
« Reply #2 on: March 03, 2014, 07:29:10 pm »

I finally got around to trying recording via Dante on my new A&H GLD 112.


Set up static addresses on both the Dante card and MacBook Pro (OSX 10.9.1, 2.8 GHz Intel Core 2 Duo, i.e. old laptop). 10.0.1.x
Set up Dante for 32*32.
Set DVS to 10ms latency (highest setting). Set Cubase to use a 2048 sample buffer (highest setting).
Turned off wifi on the MacBook Pro.
No network, just a normal cat 5 cable between MacBook Pro and Dante primary port on option card.
GLD control network isn't hooked up to anything.
Dante Controller (latest version downloaded tonight) says all is well. GB connection, no errors, no log errors, IP addresses are cool, everything routes just fine...


Tried recording 10 tracks in Reaper, and 24 tracks in Cubase, and I get the same problem, random spikes across random tracks.  Cubase has an option for 'external clock' which I selected and deselected, it made no difference.


FWIW, recording works flawlessly on my new X32 via USB on the same system.


Any ideas what my problem might be?

Is the Audio Clock Source on your GLD set to "Internal"? Also open Dante Controller to set "Preferred Master" and "Slave to external wordclock" for the GLD card. I had to make sure these were set on my iLive, as I, too, had clicks and pops. All is clear and solid for me now.
« Last Edit: March 03, 2014, 08:04:42 pm by Alan R Roberts »
Logged

Mark McFarlane

  • Hero Member
  • *****
  • Offline Offline
  • Posts: 1508
  • Middle East
    • Arkose Records
Re: Dante recording has spikes
« Reply #3 on: March 03, 2014, 11:13:39 pm »


Thanks David and Adan. Setting the GLD to use the Dante card as the clock master seems to have fixed the problem.  Setting the Dante card as  'preferred master' in Dante Controller seems to have had no effect.


Setting "Enable sync to External" for the Dante card seems to throw a bunch of repeating errors (Audio mute on and off) in the Dante controller. log history.  This makes sense, reading the documentation it appears that setting this checkbox is in essence telling the Dante card to clock from the host (GLD), but I just I just told the GLD to get clock from Dante option card.


I may be reading this wrong


Enable Sync To External
Forces the Dante module to derive its clock from an external source - either from a host device word clock, or from an auxiliary device.
This will also ensure that this Dante device becomes master clock for the relevant clock domain (unless another device has 'Preferred Master' selected). It is not normal practice to configure more than one device per clock domain with an external clock source. In this case, the user is assumed to have synchronized external word clock sources (e.g. house clock).
Where the checkbox is present but greyed-out (and inactive), it means that the Dante device can be slaved to an external word clock, but it cannot be set directly from Dante Controller - it must be done via the host device user interface, or via some other method (e.g. third-party control software). If the checkbox is greyed out and populated, it means that the Dante device is currently slaved to the external clock.
If N/A is displayed, it means that the device does not support slaving to an external word clock.




I only tested for a few minutes, I'll let it run for a few hours and try the "Enable
Logged
Mark McFarlane
ARKOSERECORDS
Turn down what's too loud.

Ian Routley

  • Newbie
  • *
  • Offline Offline
  • Posts: 9
Re: Dante recording has spikes
« Reply #4 on: March 04, 2014, 03:06:05 am »

Will be watching this with interest, as we start Dante recording from a Soundcraft Exp3
Logged

Jeff Simpson

  • Newbie
  • *
  • Offline Offline
  • Posts: 8
Re: Dante recording has spikes
« Reply #5 on: March 04, 2014, 04:30:02 am »

Hi Mark

The wording in Controller is slightly confusing, as when it says 'External Wordclock', it means external to the Dante card, as opposed to 'to the product the Dante card is plugged in to'. In the case of the GLD, this corresponds to the GLD's internal clock.

The correct settings for your setup are to have the Dante card set to slave to external word clock, and to set the GLD clock to Internal (As Alan suggested). The preferred master setting only has an effect when you have more than one Dante device in your system, excluding any Virtual Soundcard instances (which must always be clock slaves).

Hope this helps

- Jeff, A&H
Logged
Allen & Heath UK

Mark McFarlane

  • Hero Member
  • *****
  • Offline Offline
  • Posts: 1508
  • Middle East
    • Arkose Records
Re: Dante recording has spikes
« Reply #6 on: March 04, 2014, 10:51:37 am »

Hi Mark

The wording in Controller is slightly confusing, as when it says 'External Wordclock', it means external to the Dante card, as opposed to 'to the product the Dante card is plugged in to'. In the case of the GLD, this corresponds to the GLD's internal clock.

The correct settings for your setup are to have the Dante card set to slave to external word clock, and to set the GLD clock to Internal (As Alan suggested). The preferred master setting only has an effect when you have more than one Dante device in your system, excluding any Virtual Soundcard instances (which must always be clock slaves).

Hope this helps

- Jeff, A&H


Thanks Jeff, upon re-reading Alan and David gave different setups, I followed David's. I assumed Alan meant "is the GLD set to internal sync" as if that was a bad thing :)


Anyway, I set the GLD to use its internal clock, and set Dante to use 'external sync' (as shown below) and I have 7 minutes of clean recording. I'll let it run a few hours. Thanks again.



Logged
Mark McFarlane
ARKOSERECORDS
Turn down what's too loud.

Mac Kerr

  • Old enough to know better
  • Administrator
  • Hero Member
  • *****
  • Offline Offline
  • Posts: 3336
  • Audio Plumber
Re: Dante recording has spikes
« Reply #7 on: March 04, 2014, 12:07:40 pm »

Thanks David and Adan. Setting the GLD to use the Dante card as the clock master seems to have fixed the problem.  Setting the Dante card as  'preferred master' in Dante Controller seems to have had no effect.

In any network audio system, the network should be the clock master to all hardware devices.

Mac
Logged

Josh Millward

  • The Basement
  • Sr. Member
  • *
  • Offline Offline
  • Posts: 393
  • Meridian, MS
    • MediaMatrix
Re: Dante recording has spikes
« Reply #8 on: March 04, 2014, 12:30:37 pm »

In any network audio system, the network should be the clock master to all hardware devices.

Mac

Absolutely.

Never should the network have to be clocked from a specific hardware device.

Other manufacturers have made this mistake before. Then they realized that they can't use two of their own devices on a network together. That sort of defeats the purpose of having a network. Fortunately they fixed this problem.
Logged
Josh Millward
Peavey Commercial Audio Technical Services
http://www.peaveycommercialaudio.com/
http://peaveyoxford.com/forum/

Mark McFarlane

  • Hero Member
  • *****
  • Offline Offline
  • Posts: 1508
  • Middle East
    • Arkose Records
Re: Dante recording has spikes
« Reply #9 on: March 04, 2014, 12:55:35 pm »

Thanks again Jeff and Alan.

Setting the GLD112 to use it's internal clock, and the Dante option card to "Enable Sync To External" enabled me to record 1.5 hours of glitch free 24-channel audio before Cubase threw an error which I suspect is unrelated to Dante. 

I've never tried to multi track on this laptop so I have a tad more work to do.  I have many years of DAW experience so I should be able to work my way through the Cubase problem, possibly as simple as using an external disk rather than the 5400RPM system disk.

Anyway, Dante on the GLD seems to be working as expected.  I have a "big band" gig Thursday night so I'll give it a whirl.
Logged
Mark McFarlane
ARKOSERECORDS
Turn down what's too loud.
Pages: [1] 2 3 ... 9   Go Up
 


Page created in 0.132 seconds with 24 queries.